Home 0P3N Blog Nslookup "help Is Not Yet Implemented"
Ready to Start Your Career?
Create Free Account
authors profile image
January 1, 2016

Nslookup "help Is Not Yet Implemented"

January 1, 2016
authors profile image
January 1, 2016
Hello, i am just starting with learning how to hack. Some of my friends are proficient at it and im giving it a try. I am running on Kali linux and when going into the terminal and using nslookup i keep getting "help is not yet implemented" i know what this means... but why is it saying this? Am I using a weird version? Is it not fully installed? I am very confused since it was working in the tutorial video. thanks in advance :) Hey mate, Have you tried to run the full syntax? nslookup domain.com Are you root also, times to times you have to continue as root. Try sudo or open the terminal for administration in Kali linux, and make sure of course everything is installed probably by trying to upgrade it. Best regards, Kevin. I just tried, and indeed, apparently "help" is't a recognized command. So I looked at the man page... they explicitly say help isn't implemented there as well (along with root, finger, ls, and view. To expand on what Koert said above - yours is working exactly as intended. Use "man nslookup" for the manual - which MOST commands feature to display a full manual. If you get a response like "help not implemented" use some google-fu to find what you need. I was having the same issue but the help list is all over the internet so I recommend just looking at that. You can use the host command. Example: host -d www.yoursite.net I'm having the same problem and it isn't a server issue. I run help on nslookup in Debian for my Penetration Testing and Ethical Hacking course and I keep getting "The 'help' command is not yet implemented." I have looked everywhere and no one seems to have an actual answer. This is frustrating to say the least. Nonetheless it seems this is one thing I will have to learn on my own since no one in the community as of yet seems to know the answer to this bizarre mystery surrounding it. I will come back with an answer once I find it. Well I found the answer and none of you who use Linux may like the answer. Apparently it means what it says. When it says “The ‘help’ command is not yet implemented.," it means it doesn't exist. Apparently Linux found no reason to implement the 'help' command. I still think the Linux Bash shell is way better to use than the windows command interface and this really isn't that much of a big deal since all of these commands can be found in the manual and online as well.
Schedule Demo

Build your Cybersecurity or IT Career

Accelerate in your role, earn new certifications, and develop cutting-edge skills using the fastest growing catalog in the industry