Home 0P3N Blog Kali 2.0 Experience?
Ready to Start Your Career?
Create Free Account
authors profile image
January 1, 2016

Kali 2.0 Experience?

January 1, 2016
authors profile image
January 1, 2016
Hi Guys, Installed Kali 2.0 last night. I think it looks awesome. A bit of CentOS touch in design.. :) No bugs detected yet. Did you?! Any suggestions on any additional libs or or dependencies to install after fresh install? Just share your experience! :) Impact .. oh and what new tools did you noticed? I am going to review it as soon as I have some spare time. I am pretty sure it wont be disappointing though. Newly refreshed UI thats it...... along some bug fixes and some metasploit easy upgrade systems.... Overall fine. -- xMidnightSnowx Only just installed and had a quick look but on first impression it all seems good. Does someone can help installing drives on it? :p Hi, hope this new version of Kali do more things and be more productive! not installed yet but as soon I have time I´ll do it, do some research if you need additional info about libs and dependencies. new kali 2.0 smooth refresh better UI new tools better wireless ap. this is my experience till now Would be nice to have the most popular wifi drivers pre installed Hmmm.....so far from I have tested, I like it.... /me likes new interface. (: kali 2 , ui is nice but deff more resource heavy than before, rolling updates = nice in stead of the constant apt-get. how ever the loss of metasploit i think will come to show up after people have had their hands on it a while. maltego also looks refreshed. Loss of Metasploit? Only issue I've encountered is the global dark theme gives and error and doesn't work. "Error configuring settings" or something. Also if you are using apt-get dist-upgrade, make sure you change your sources.list and make sure you get all the old ones wiped out, lol. after 14 hrs of upgrading it started unpacking and installing everything, then went for updates and came across a bad repository. Stopped the whole install and I had to delete the partition and install fresh from .iso. Derp! I ended up doing a fresh install also, after the upgrade blewout my xserv and would no longer launch a gui. How ever to a give some refernce about metasploit. scroll almost to the bottom of the page. https://www.kali.org/releases/kali-linux-20-released/ Awesome. 4 of my 5 systems run Kali. I have a PC that dual boots Win7/Kali. A G5 Mac that runs Kali. I'm not a fan of Apple but taking out the Mac OS and replacing it with Kali was fun. Windows on a Mac is blahhh. Same with a Mac OS on a Mac. Linux on a Mac is Awesomeness! :) \[just my opinion\] My laptop and netbook both run Kali. Looks like I'm going to be busy with Kali installs for a while. Kali just happens to be one of my favorite OS's. Hack in the Box running on a Debian based system doesn't get any better than that. :) Oh, I didn't think anything of it when I saw the MSF icon. I wasn't thinking about it not bring pro. That sucks. Good thing I still have Kali 1 on a disc, and a physical machine. ;) I didn't lose my gui, but I lost about 95% usability of the system. All I could really do was upload the few files I had and email them to myself before the fresh install. I didn't have anything important on it, so it wasn't a backup before install deal. Turned out ok anyhow, and let me say..the fresh install took about 1 hr, the apt-get dist-upgrade was over 12 hrs...no thanks! For me the design is good ,but not airodump is not working anymore !Look like my wifi adapter is not good now ! ARP linktype is set to 1 (Ethernet) - expected ARPHRD\_IEEE80211, ARPHRD\_IEEE80211\_FULL or ARPHRD\_IEEE80211\_PRISM instead. Make sure RFMON is enabled: run 'airmon-ng start wlan1mon ' Sysfs injection support was not found either. I have found how to solve this problem but still am a bit deceive of this version for me my old kali was better . So far Kali 2.0 compared to the previous version has made my netbook run noticeably slower. It is nice to look at. I cant install Firestarter or fwbuilder because of broken packages that it tells me to fix, but can't fix them. So far its been a painful upgrade. If it continues to be a buggy piece of crap I will go back to 1.1.0, that was working perfectly for my systems. I was all excited about it now I'm just feeling disappointed. Edit: I upgraded the packages and now my WiFi is stuck in airplane mode. Well that does it for me. Boooo! Hisssssss! Im going to put 110 back in screw 2.0 :\[ I was so looking forward to installing Kali this weekend :( Not so sure anymore after the comments I just read. Koert By all means install Kali just don't go with 2.0. \[not recommending it if its your 1st time with kali as there is less support with a new release.\] 1.10 is good and has a lot of interesting toys. :) Im downgrading to 1.10 right now. Koert, give it a shot. Not everyone is having the same experience. I dual-booted it alongside Windows 10 on my laptop, and everything is fine. I'm also running it in VMs on both my home desktop and work desktop with no issues. Install 2.0, and if it doesn't work for you, then install 1.10. Don't take anyone's word for it, personal experiences vary. I'm really confused about the comment that was made regarding Metasploit. The Metasploit Framework is installed, just like it always has been. Armitage is installed if you want a GUI, as well. The only tool that did not work out-of-the-box for me is armitage (it says exception error on a gem). But after an apt-get clean -> apt-get update -> apt-get upgrade everything works very well. Welcome Kali 2.0 :) Kali on MAC?! Now thats the way to go @Doktor!! :D Kali 2.0 does not include commercial editions of Metasploit that are Community, Express and Pro versions. Kali 2.0 includes, by default, a version of Metasploit Framework. EDIT: Originally, I assumed that it had to do with making room for other applications that were more important than Metasploit Community. But, I went to Rapid7's site and found this. https://community.rapid7.com/community/metasploit/blog/2015/08/12/metasploit-on-kali-linux-20 So, it's because Rapid7 doesn't officially support Kali 2.0 yet. But, if you read through, Community can be installed. Either way, it is false to make a statement that Metasploit is not installed. This will turn users away from trying a new version of Kali, when there is no reason to not try it. The framework is there, and they even installed Ruby 2.0 in order to ensure that Metasploit runs faster. kali is the best a little slow but the best 2.0 in my opinion is good for everyday use as well as a work horse, but 1.0, 1.1 Kali it's only a work horse if you know what I'm saying. I'm excited to try Kali 2.0!!! Thanks for feedbacks :D Cheers @Pritam Slow?! Which part of it is slow for you??? The new UI is my favorite thing about this new release. I started using Kali as soon as Backtrack was phased out. The tools are much easier to use. HI I have downloaded the file from kali.org and I am trying to get it on a usb memory stick (perstitance perffered). I have tried linux usb creator,rufus,unetbootin,win32disk imager. I have isos: 2, 1.09,1.0.8,1.10a and 2 mini. NONE thing is working please please help me get it working of a usb persistence drive please. I am planning on starting the forensic course and I need it for the course. I don't want to use my laptop with windows 10 as my wife uses it to so she wants to uses it. Should I use it on the hard drive and if so how much room should i put a side for it. I have already commented on kali.org and I have no reply. Surely their is someone else in my position whom wants the same result? Kind Regards ShenLun Hi @ShenLun You need full x64 (not mini) bit Kali 2.0.iso (If your machine is 32 bit well then you need 32 bit .iso). Try to use YUMI ( https://www.pendrivelinux.com/yumi-multiboot-usb-creator/ ) to put your .iso to your USB drive. And it should boot up if you configure BIOS settings to boot from USB first. Hope that helps. I don't know your situation (What exactly doesn't work for you?) If you still have issues ask! Impact @Impact I have a x64 bit machine and will try dowwnloading the x32 bit file and try again with yumi. my problem is that i get either of the following 2 messages: I use Yumi and get the following error message g2lder.mbr can not be found win32 disk imager Boot Failure a proper digital signature was not found. One of the items on the selected boot device was rejected by the secure boot feature. When i use vmware it goes to the load screen and i configure the virtual machine and then it just shows a blue screen with a white section below. no response to keyboard commands so i crl alt and power down the virtual machine I don't have linux and want to learn with this one as its part of my course later on in the year.computer forsencis but as it's been 5 years since i touched a linux os i wanted a head start on it. Will update you on my progress. Since becoming disabled i have free time to learn and my friend in i.t. all i could be at my age (34) was a lvl help desk or content administrator. I really want to prove it to him that i can make in computer foresencis but i am starting small with security+ course first Might be over simplify it but just pull down the Kali vm and mount it.? Or try unetbootin @od1tspyd3r I have tried unetbootin and I get the same result. As for the vmware/vmachine I gave my results in the previous post on my trials so far. Are you suggesting that I am able to download the kali vmware straight to the usb and boot it from their as a persitant vwmare usb? Kind Regards ShenLun @od1tspyd3r same result with yumi. \\g2lder can not be found or is corrupt blah blah blah Thanks for your input Hi @ShenLun, According to error you have problems with grub2 loader(g2ldr.mbr). Master Boot Record file is ether corrupt or missing or something along those lines. Never had this problem myself, try to google the error. Have no time for decent research right now. Check this out: https://neosmart.net/wiki/no-g2ldr/ That might help. Keep us updated I'm sure we can help you to install it in some state or form at some stage ha :) I would recommend you to install it on VMware Player. Oh and the blue screen is normal, you just have to give it some time and it will start to install. Well at-least that was happening with Kali 1.0 and i think 1.1. So try to install VM again and give it some time to warm up :) Im not sure what you trying to do with USB.. Because if you put Kali ISO on to your USB key you will only make that USB bootable (Like install CD), then you have to install it on your hard drive (then your system would have whats called Dual-Boot, on restart you would choose what OS do you want to operate Win or Kali). Probably you know that but anyway I just wanted to make it clear just in case. (Don't know how advanced you are in computing and sys administration). Anyway keep us updated. PS Nobody can tell you what you can and what you can't! Be relentless, believe in yourself and you can be anything you want! Peace Impact @ShenLun, let me back up and ask for " what is your end goal?" i.e i want my win 8 pc with virtual box to run kali linux or i want to dual boot. +1 @impact "PS Nobody can tell you what you can and what you can’t! Be relentless, believe in yourself and you can be anything you want! Peace Impact" HI Guys I got it working, stupid bios had an additional advanced section in the management the that changed the boot settings. So to answer your question @od1tspyder, I wanted a dual boot windows 10 and kali operating system. firstly i want to thank you all on your words of in couragement @impact @od1tspyd3r @RobertS just to name a fewI really look forward to deliver deeper into this course. Because IRL friends and they all either blew me off (one claiming to be a expert at linux) the others experts in it with bachelors and jobs saying i won't be able to achieve this. second problem. i just need to find a broadcom adapter and realtek audio adapter for linux distro because i have no wifi in kali. for now however i know i can access kali and I am happy that i can access my windows partition as well without reformatting it. How cool is that!. Well I am off back to the books barely on my 4th lesson on the first module because I spent so much time getting this kai issues sorted amongst with irl thing Kind Regards ShenLun Hi @ShenLun, Welcome to Linux! ha :) Try to update you Kali in command Terminal type : apt-get update && apt-get dist-upgrade && apt-get upgrade -y That might upgrade some drivers or just google your card model install for Debian based Linux OS. PS Anyone can be an expert in Linux with a little bit of time,effort and Google! :) Bachelors degree is nothing compared to Professional Certificates!!! Whatever they were lecturing 10 years ago they have still same syllabus now, which means its ether old content or they they deliver very basic info cause there's no time to go deeper and to specific topics, at the end of the day it's all about the money :) So you can tell them they can wipe their arses with their Bachelors Degree :D I know people who never went to college and are absolute Stars in Cyber Security. If you pick to do what you like to, there no limit man. And at the end of the day when you'll find a job and you will do what you love to do + get high salary... oh man, its a dream! Its nice that we have these free Prof Certs courses in Cybrary and I see how we are building community of like-minded people, everyone is helping each other out. It's amazing guys. Regards Impact Cool, UI better....but actually I thought better, in the end it didn't impress me so much...ehm.. I was having a shite time of 2.0 but Kali is my favorite OS so I installed it once again. I'm glad I did aside from the problems I had with it, I have to say its awesome. I'm running it with enlightenment desktop environment. The default was making my netbook run like a slow clunky dump-truck. So if anyone is experiencing the same sluggishness you might want to look into changing the desktop environment as a possible reason why. Its as easy as running "apt-get install". | Desktop Environment | Memory Used | | ---------------------|------------:| | Enlightenment 0.18.8 | 83.8 MiB | | LXDE 0.5.5 | 87.0 MiB | | XFCE 4.10.2 | 110.0 MiB | | LXQt 0.7.0 | 113.0 MiB | | MATE 1.8.1 | 123.0 MiB | | Cinnamon 2.2.13 | 176.3 MiB | | GNOME3 3.12.2 | 245.3 MiB | | KDE 4.13.1 | 302.6 MiB | | Unity 7.2.0.14 | 312.5 MiB | Source: [memory-consumption-of-linux-desktop-environments](https://flexion.org/posts/2014-03-memory-consumption-of-linux-desktop-environments.html) Yesterday I installed it but it has a failure with installing the GRUB loader so this installation ended up with a total failure. I checked the solution on how to fix the problem but for the first time it's not a good impression! I took a look at it via LiveUSB and it looks pretty awesome ! ;) Can't hardly wait fixing the GRUB issue ! :D Greets, @danesz012 Is metasploit full in built ? Working all metasploit tools ? I'm loving the new WPS-Pixie attack. I'm in love with everything Kali 2.0 now That's the OS I'm using now and it's just wonderful So much improvement Great! The new UI is pretty great and allows me to easily find the stuff that I need. It is an overall improvement over 1.1a
Schedule Demo

Build your Cybersecurity or IT Career

Accelerate in your role, earn new certifications, and develop cutting-edge skills using the fastest growing catalog in the industry