Home 0P3N Blog Help With Kali WiFi In VMWare
Ready to Start Your Career?
Create Free Account
authors profile image
January 1, 2016

Help With Kali WiFi In VMWare

January 1, 2016
authors profile image
January 1, 2016
I'm trying to install drivers so that my wifi works but i can't do it. I alredy tryed to install, but asks me to install ieee80211 ... (which also already tried, but with no results) Any idea what should I do? :s Hi, can you post the wifi adapter information? (chipset, model, etc) Without that informations it's hard to help you : ) Try running "ifconfig" in terminal and see if it picks up your card. I had this issue with my card (broadcomm..IIRC) on my laptop. It took some tweaking. Get back to us and we'll be happy to assist you. Grab a screen shot of ifconfig and link us to it or post it. In Kali console doesn't apear my wifi adapter (ifconfig only show eth0 and lo description), but I know that is a Inter(R) Dual Band Wireless-AC 3160 (is this the Chipset and model?), because is the one that I used to configure my Network connection (Bridged). I'm using VMware (in the future maybe I'm going to do dual boot) with the configurations like this: Memory: 2GB Processors: 2 Hard Disk (SCSI): 30GB Network Adapter: Bridged(Automatic) . . @Dallas @docsimo85 :D Hello. "Help with Kali" should be "Help with WiFi running Kali on a VM". Your problem my best guess is most likely with the WiFi adapter itself. Kali doesn't play well with some and works awesome with others. Then on top of that you're running it through a VM. Kali plays well with: Atheros AR9271 – IEEE 802.11B/G/N Ralink RT3070 – IEEE 802.11B/G/N Realtek RTL8187L- IEEE 802.11B/G List here: https://www.blackmoreops.com/2014/01/08/recommended-usb-wireless-cards-kali-linux/ Why are you using a VM with Kali when its a live bootable distro? I can suggest that you use it without the VM, booting a live DVD or even better a live USB Boot instead. The WiFi adapter will probably just work. Getting it to do fun things with Aircrack-ng or (i.e. monitor, injection etc.) is another can of worms. Hope this helps. :) Try this "aptitude install firmware-iwlwifi" I got this from [Kali & INtel Dual band](https://forums.kali.org/showthread.php?18912-Intel-Dual-Band-Wireless-AC-7260-Not-Recognized)While that is the 7260, I'd image the firmware is the same for all Intel Dual Bands. And this one [Linux AC 3160](http://www.linuxquestions.org/questions/linux-hardware-18/help-with-wifi-driver-intel%AE-dual-band-wireless-ac-3160-a-4175515014/) is almost exactly one year ago, lol. Oh, and one more...[Ubuntu forums - AC 3160](http://ubuntuforums.org/showthread.php?t=2214075)Run through those threads and see what you get, then report back to us. I'll answer as quickly as I can google stuff when I get home from work, haha. I know I had to do quite a bit of research to get my WiFi NIC working with Kali, and with 1.1 it would still just randomly stop working, so far on 2.0 I've had no issues, but then again I haven't really done anything on 2.0 yet..except let it sit idle and look pretty while at work. :D @Dallas I tried to do the steps in both the websites but now when I do the command "iwconfig" it show's: eth0 no wireless extentions. lo no wireless extentions. And at first when I try to do the "aptitude install firmware-iwlwifi", the output was something like "0 updated, 0 new, 0 to be removed and 124 that weren't update" or something like that :s Hi @jk13, I wonder if the issue might be due to your VMWare config, rather than a driver issue with Kali. Assuming you have an ethernet connection, setting your virtual nic to "Bridged (automatic)" might be part of the problem; the virtual NIC kali is using is getting mapped to an ethernet (rather than wifi) device. If your wireless card is PCI, then I'd say you should add a second NIC to your VMware config and have it link directly to your wifi card. If you are using a USB wireless card, ensure you have actually directed VMWare to **Connect (disconnect from host)** the device to the VM. This is usually NOT automatically done, unless you have specifically directed VMware to always connect USB devices. --Stark I'm trying to install drivers so that my wifi works but i can't do it. I alredy tryed to install, but asks me to install ieee80211 ... (which also already tried, but with no results) Any idea what should I do? :s @STARK :) I'm using the wireless card of my one PC, how can I add a second NIC? How can the "Bridged (automatic)" affect and how can I resolve it? Not sure on VMWare...but I bridged the network connection in Virtualbox on a family member's instance of Kali running in a VM. Works fine and grabs an IP from the wireless access point's DHCP scope...... @jk13 Assuming you are running windows 7 or later: - run the "Virtual Network Editor" program (found in the VMWare folder) as Administrator - Click the "Add network" button and select a virtual network name from the drop down list, any will work - Select the network you just created, and ensure it's set to "Bridged" and from the "Bridged to:" drop-down menu select your Wireless card. \[**[screenshot](http://postimg.org/image/e8il4hms9/)**\] - open up VMware and your Kali VM. Click "Edit Virtual Machine Settings" - From the hardware tab, select the "Add" option near the bottom, and then the "Network Adapter" option - Select the "Custom" opton, and in the drop-down box select the new Virtual NIC we created with the Virtual Network Editor \[**[screenshot](http://postimg.org/image/9atx4etz3/)**\] Edit: I should have asked before actually but, are you connected to the internet with a cable or wireless? My solution was based on you being connected via ethernet. --Stark@STARK I'm connected via wireless :s And I don't have any file/app called "Virtual Network Editor" @jk13 Ohhh ok. well the issue is due to the fact that VMware, when it translates your physical wireless NIC to the virtual nic that Kali uses, it's getting translated as an Ethernet connection instead of wireless. To get wireless networking with Kali you will need one of the supported USB wifi cards: http://www.inkthat.info/hacking-with-kali-linux/kali-linux-supported-wireless-cards/ --Stark Thanks @STARK :) I've this one: [](http://www.tp-link.com/en/products/details/cat-11_TL-WN725N.html)But I don't know if it works for injection :p @jk13 link or image didn't come through. To get wireless support with Kali you may have to do what @daleksek suggested earlier in this topic: Run it Live --Stark Maybe this works @STARK: [Wireless USB](http://www.tp-link.com/en/products/details/cat-11_TL-WN725N.html)Yes, I'm trying that, today I got it working (the kali, not the wireless), tomorrow I will try to work with it. That **might** work; It's pretty close to the "TP-LINK TP-WN722N" that can be found on the list of supported cards (http://www.inkthat.info/hacking-with-kali-linux/kali-linux-supported-wireless-cards/) Does anybody else happen to know if the "TP-LINK TL-WN725N" is supported with Kali and can handle packet injection? --Stark @stark TP-LINK TL-WN725N doesn't support Kali OS. However, TP-LINK TP-WN722N works pretty fine on it. (I have tried both.) @thelalitrawat too bad :(. Thanks for the Update! @JK13 - Were you able to resolve your issue? Hi, I just want to know if this will work with my Kali Sana 58dBi directional high gain antenna, high sensitivity long range Range over 500-800M(indoor) / 3KM(outdoor) with connection Ralink 3070 chipset Standards: IEEE 802.11 B/G Data rate: 802.11b: 11Mbps 802.g:54Mbps Data Modulation Type: IEEE 802.11b: (DSSS), 5.5/11Mpbs(CCK) 2Mbps(DQPSK), 1Mbps(CCK) IEEE 802.11g: (OFDM), 48/54Mpbs(64-QAM) 24/36 Mbps(16-QAM), 12/18Mbps(QPSK),6/9Mbps(BPSK) Thanks! @iamkenichi The Ralink 3070 chipset works with Kali. thanks @KappaG
Schedule Demo

Build your Cybersecurity or IT Career

Accelerate in your role, earn new certifications, and develop cutting-edge skills using the fastest growing catalog in the industry