Host won't let VM use USBVirtualization Management Course

Begin Learning Cyber Security for FREE Now!

FREE REGISTRATION
Already a Member Login Here

Home Forums Courses Virtualization Management Course Host won't let VM use USB

This topic contains 10 replies, has 5 voices, and was last updated by  subirkochar 2 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #27178

    Dallas
    Participant

    I’ve Googled, I’ve Binged I get the same results, which do not help me. I put in the TP-Link on my WINDOWS 7 HOST Machine, I can’t use it in VM because it’s not “disconnected” from the Host. How would I go about making Windows “ignore” it while still recognizing it’s plugged in so I can utilize it through Kali in my VM?

    I also posted this in the Break Room forum, since I wasn’t sure where it should go. Max Exposure!!

    Thanks in advance.

    P.S. When I click “Connect (Disconnect from host)” in VM it says that the device disconnect from host failed. I don’t see anything using it and I’ve tried disabling it.

    #27180

    angut
    Participant

    Hi Dallas, what version of VMWare Workstation are you using? I can’t find any information about sharing a WUSB key, but I have version 11 on a notebook at home and I can try to replicate what you are trying to do and see how it goes, but it would be nice to know your version, thanks in advance.

    #27181

    Dallas
    Participant

    VM Workstation 12 Player. 12.0.0 build-2985596.

    #27209

    angut
    Participant

    OK, I just tried with a Windows 8.1 host, Fedora VM, VMWare Workstation 11.0 and a Linksys WUSB, I’m not proficient in Linux, so I could not get the WUSB to work, but using dmesg I can see the when the usb connects and disconnects from the VM, I’m guessing it might be something related to the host, I would try the next 3 things:

    Change the UAC Settings to never notify if not already
    Run VMWare Workstation as administrator
    Try connecting the usb wireless nic when your VM is the active Window so it won’t go to the host first

    Hope that helps.

    #27338

    angut
    Participant

    Any update on your issue? Regards.

    #27343

    Dallas
    Participant

    Yeah, I was pretty sure I posted it last night, lol. Who knows where I posted it though. Oh well.

    My UAC was already set to never notify (running as Admin)
    Ran VMWare as Admin, nothing.
    Connect the NIC while VM window was active and disconnected my eth0 and it worked! It now connects to it.

    Won’t allow me to use it for airodump-ng in Kali (gives multiple errors about duplicate name, Siocsfflags error: Name not unique on network) and something else. I disconnected and jumped on my Lubuntu VM, installed aircrack-ng and tried, after downing, changing to monitor mode, etc with “wlan0 down, mode monitor, wlan0 up” etc I can get it to monitor and dump.

    But then I kept getting directory errors with aircrack-ng even though I was referencing the correct path/file for the worlist and the file to test against. At that point I called it quits for the night (well..early morning lol) I’ll play with it more tonight.

    Thanks for the help, It’s greatly appreciated!

    #27388

    angut
    Participant

    Sorry I can’t provide more help, like I said, I’m not proficient with Linux, at least not right now, I’m working on building those skills, but at least you are now facing a different problem, that means you moved forward, I hope you can figure it out soon, keep it up.

    #28641

    Kaushal
    Participant

    Which Hypervisor is best for security?

    #28643

    angut
    Participant

    Hi Kaushal, I’m not a security expert, maybe a security expert can shine some light on your question, but I have some understanding of two mainstream hypervisors, VMWare and Hyper-V, taking those two under account I consider VMWare to be a much mature product, and I’m assuming it is better in the field of security too, but not very sure, but one thing we have to consider is Hyper-V is still a Windows OS, or the primary partition is, VMWare doesn’t even have a primary partition anymore, and ESXi is a very trimmed down OS, just what you need for the virtualization layer, nothing more, so, between those two I would definitively would go with VMWare, but like I say, maybe someone with expertise in security can say more, or people who works with other hypervisors. Hope this helps though.

    #36822

    CyberWolf
    Participant

    Did you try to remove the USB-controller and add a new USB-controller?
    this could help.

    #63716

    subirkochar
    Participant

    good

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Our Revolution

We believe Cyber Security training should be free, for everyone, FOREVER. Everyone, everywhere, deserves the OPPORTUNITY to learn, begin and grow a career in this fascinating field. Therefore, Cybrary is a free community where people, companies and training come together to give everyone the ability to collaborate in an open source way that is revolutionizing the cyber security educational experience.

Cybrary On The Go

Get the Cybrary app for Android for online and offline viewing of our lessons.

Get it on Google Play
 

Support Cybrary

Donate Here to Get This Month's Donor Badge

 
Skip to toolbar

We recommend always using caution when following any link

Are you sure you want to continue?

Continue
Cancel