Help with Kali WiFi in VMWareThe Break Room

Begin Learning Cyber Security for FREE Now!

FREE REGISTRATION
Already a Member Login Here

Home Forums The Break Room Help with Kali WiFi in VMWare

Tagged: 

This topic contains 24 replies, has 10 voices, and was last updated by Profile image for iamkenichi iamkenichi 1 year, 7 months ago.

Viewing 20 posts - 1 through 20 (of 25 total)
  • Author
    Posts
  • #20933
    Profile image for jk13
    JK13
    Participant

    I’m trying to install drivers so that my wifi works but i can’t do it.
    I alredy tryed to install, but asks me to install ieee80211 … (which also already tried, but with no results)
    Any idea what should I do? :s

    • This topic was modified 2 years, 3 months ago by Profile image for stark STARK. Reason: updated title
    #20956
    Profile image for docsimo85
    docsimo85
    Participant

    Hi,
    can you post the wifi adapter information? (chipset, model, etc)
    Without that informations it’s hard to help you : )

    #21041
    Profile image for dallashannah3
    Dallas
    Participant

    Try running “ifconfig” in terminal and see if it picks up your card. I had this issue with my card (broadcomm..IIRC) on my laptop. It took some tweaking. Get back to us and we’ll be happy to assist you.

    Grab a screen shot of ifconfig and link us to it or post it.

    #21097
    Profile image for jk13
    JK13
    Participant

    In Kali console doesn’t apear my wifi adapter (ifconfig only show eth0 and lo description), but I know that is a Inter(R) Dual Band Wireless-AC 3160 (is this the Chipset and model?), because is the one that I used to configure my Network connection (Bridged).

    I’m using VMware (in the future maybe I’m going to do dual boot) with the configurations like this:
    Memory: 2GB
    Processors: 2
    Hard Disk (SCSI): 30GB
    Network Adapter: Bridged(Automatic)
    .
    .

    #21424
    Profile image for jk13
    JK13
    Participant
    #21433
    Profile image for daleksek
    Doktor Frankenstein
    Participant

    Hello. “Help with Kali” should be “Help with WiFi running Kali on a VM”.
    Your problem my best guess is most likely with the WiFi adapter itself. Kali doesn’t play well with some and works awesome with others. Then on top of that you’re running it through a VM.
    Kali plays well with:
    Atheros AR9271 – IEEE 802.11B/G/N
    Ralink RT3070 – IEEE 802.11B/G/N
    Realtek RTL8187L- IEEE 802.11B/G

    List here:
    http://www.blackmoreops.com/2014/01/08/recommended-usb-wireless-cards-kali-linux/

    Why are you using a VM with Kali when its a live bootable distro? I can suggest that you use it without the VM, booting a live DVD or even better a live USB Boot instead. The WiFi adapter will probably just work. Getting it to do fun things with Aircrack-ng or (i.e. monitor, injection etc.) is another can of worms. Hope this helps. 🙂

    #21439
    Profile image for dallashannah3
    Dallas
    Participant

    Try this “aptitude install firmware-iwlwifi”

    I got this from Kali & INtel Dual band

    While that is the 7260, I’d image the firmware is the same for all Intel Dual Bands.

    And this one Linux AC 3160 is almost exactly one year ago, lol.

    Oh, and one more…Ubuntu forums – AC 3160

    Run through those threads and see what you get, then report back to us. I’ll answer as quickly as I can google stuff when I get home from work, haha.

    • This reply was modified 2 years, 3 months ago by Profile image for dallashannah3 Dallas. Reason: Additional Link
    #21442
    Profile image for dallashannah3
    Dallas
    Participant

    I know I had to do quite a bit of research to get my WiFi NIC working with Kali, and with 1.1 it would still just randomly stop working, so far on 2.0 I’ve had no issues, but then again I haven’t really done anything on 2.0 yet..except let it sit idle and look pretty while at work. 😀

    #21565
    Profile image for jk13
    JK13
    Participant

    @dallas I tried to do the steps in both the websites but now when I do the command “iwconfig” it show’s:
    eth0 no wireless extentions.
    lo no wireless extentions.

    And at first when I try to do the “aptitude install firmware-iwlwifi”, the output was something like “0 updated, 0 new, 0 to be removed and 124 that weren’t update” or something like that :s

    #21569
    Profile image for stark
    STARK
    Keymaster

    Hi @jk13,

    I wonder if the issue might be due to your VMWare config, rather than a driver issue with Kali.

    Assuming you have an ethernet connection, setting your virtual nic to “Bridged (automatic)” might be part of the problem; the virtual NIC kali is using is getting mapped to an ethernet (rather than wifi) device.

    If your wireless card is PCI, then I’d say you should add a second NIC to your VMware config and have it link directly to your wifi card.

    If you are using a USB wireless card, ensure you have actually directed VMWare to Connect (disconnect from host) the device to the VM. This is usually NOT automatically done, unless you have specifically directed VMware to always connect USB devices.

    –Stark

    #21579
    Profile image for jk13
    JK13
    Participant

    @stark 🙂

    I’m using the wireless card of my one PC, how can I add a second NIC?

    How can the “Bridged (automatic)” affect and how can I resolve it?

    • This reply was modified 2 years, 3 months ago by Profile image for jk13 JK13.
    #21582
    Profile image for cisatrainee1
    cisatrainee1
    Participant

    Not sure on VMWare…but I bridged the network connection in Virtualbox on a family member’s instance of Kali running in a VM. Works fine and grabs an IP from the wireless access point’s DHCP scope……

    #21591
    Profile image for stark
    STARK
    Keymaster

    @jk13

    Assuming you are running windows 7 or later:

    • run the “Virtual Network Editor” program (found in the VMWare folder) as Administrator
    • Click the “Add network” button and select a virtual network name from the drop down list, any will work
    • Select the network you just created, and ensure it’s set to “Bridged” and from the “Bridged to:” drop-down menu select your Wireless card. [screenshot]
    • open up VMware and your Kali VM. Click “Edit Virtual Machine Settings”
    • From the hardware tab, select the “Add” option near the bottom, and then the “Network Adapter” option
    • Select the “Custom” opton, and in the drop-down box select the new Virtual NIC we created with the Virtual Network Editor [screenshot]

    Edit: I should have asked before actually but, are you connected to the internet with a cable or wireless? My solution was based on you being connected via ethernet.

    –Stark

    • This reply was modified 2 years, 3 months ago by Profile image for stark STARK.
    #21599
    Profile image for jk13
    JK13
    Participant

    @stark

    I’m connected via wireless :s

    And I don’t have any file/app called “Virtual Network Editor”

    #21600
    Profile image for stark
    STARK
    Keymaster

    @jk13 Ohhh ok. well the issue is due to the fact that VMware, when it translates your physical wireless NIC to the virtual nic that Kali uses, it’s getting translated as an Ethernet connection instead of wireless.

    To get wireless networking with Kali you will need one of the supported USB wifi cards:
    http://www.inkthat.info/hacking-with-kali-linux/kali-linux-supported-wireless-cards/

    –Stark

    #21747
    Profile image for jk13
    JK13
    Participant

    Thanks @stark 🙂

    I’ve this one:

    But I don’t know if it works for injection :p

    #21748
    Profile image for stark
    STARK
    Keymaster

    @jk13 link or image didn’t come through.

    To get wireless support with Kali you may have to do what @daleksek suggested earlier in this topic:
    Run it Live

    –Stark

    #21777
    Profile image for jk13
    JK13
    Participant

    Maybe this works @stark:
    Wireless USB

    Yes, I’m trying that, today I got it working (the kali, not the wireless), tomorrow I will try to work with it.

    #21783
    Profile image for stark
    STARK
    Keymaster

    That might work; It’s pretty close to the “TP-LINK TP-WN722N” that can be found on the list of supported cards (http://www.inkthat.info/hacking-with-kali-linux/kali-linux-supported-wireless-cards/)

    Does anybody else happen to know if the “TP-LINK TL-WN725N” is supported with Kali and can handle packet injection?

    –Stark

    #36416
    Profile image for thelalitrawat
    Lalit
    Participant

    @stark

    TP-LINK TL-WN725N doesn’t support Kali OS. However, TP-LINK TP-WN722N works pretty fine on it. (I have tried both.)

Viewing 20 posts - 1 through 20 (of 25 total)

You must be logged in to reply to this topic.

Our Revolution

We believe Cyber Security training should be free, for everyone, FOREVER. Everyone, everywhere, deserves the OPPORTUNITY to learn, begin and grow a career in this fascinating field. Therefore, Cybrary is a free community where people, companies and training come together to give everyone the ability to collaborate in an open source way that is revolutionizing the cyber security educational experience.

Cybrary On The Go

Get the Cybrary app for Android for online and offline viewing of our lessons.

Get it on Google Play
 

Support Cybrary

Donate Here to Get This Month's Donor Badge

 

Cybrary|0P3N

DUHK: The Technique That Got the VPN Compromised
Views: 1257 / December 10, 2017
What is Docker? [Series]
Views: 2091 / December 9, 2017
Wanna-Cry Ransomware
Views: 2076 / December 9, 2017
The Abyssal Depth of the Deep Web
Views: 2055 / December 8, 2017
Skip to toolbar

We recommend always using caution when following any link

Are you sure you want to continue?

Continue
Cancel