Practicing for the CCNA Using Cisco Packet Tracer

October 19, 2016 | Views: 12611

Begin Learning Cyber Security for FREE Now!

FREE REGISTRATIONAlready a Member Login Here

Welcome to this quick guide on how to create small labs to practice routing, switching and more with the help of Cisco Packet Tracer.

This is Cisco’s network simulation software, which is used in instructor-led courses.It’s fairly quick to learn and really easy to use.  It’s

got a lot of Cisco equipment ready for you to play with. You can easily create multiple networks and connect them with various models of switches and routers.

To get it, you will have to register for a free 1-hour course at Cisco’s Networking Academy here:

https://www.netacad.com/about-networking-academy/packet-tracer/

This course is fairly straightforward and will get you up to speed with the interface and basic use of Packet Tracer.

After you get through the intro course,  you will receive the download link and you’re ready to go.
I use Packet Tracer to practice a lot of stuff.Here’s one quick example, using a few computers, two switches, and two routers:

 

Network Setup

Firstly, I set up a small network of 2 computers and assign them IP addresses.Here I’ll be using the 192.168.100.0/24 net id.

Then, I can add a Cisco 2960 Switch and connect both PCs to it.

Finally, add one Generic Router and connect it to the Switch.

step1

Now we can create another network just like before, with two computers this time with the net id 192.168.200.0/24. Assign them IP addresses and connect them to another Switch and Router.

Next, we have to connect both Routers together with a Serial cable.
Now, I can play along and add a laptop, connected via Console cable to each router, like in the real world. Or just right click on each Router and select CLI.

step2

Router Configuration

First off, we  must select not to go through the initial setup, because it’s really bad and we have to learn how to do it manually. After that, we’re in the router and ready to start configuring as you can see by the prompt Router.

By typing enable we get to Privileged mode, which is necessary to enter Configuration mode.
Do that by typing configure terminal.

1. Now we can do some real configuration.
Firstly, we need to assign IP addresses and turn on our Interfaces, since they are all down by default on a brand new Cisco router. We do that by typing

>enable
>interface FastEthernet0/0
>ip address 192.168.100.1 255.255.255.0
>no shutdown

And for Router2

>enable
>interface FastEthernet0/0
>ip address 192.168.200.1 255.255.25.0
>no shutdown

step3

2. Now we should see the links turning green, which means we got a connection from the switch to the router.
We’re not done yet, we need to set the Serial ports up as well. Our network between the two routers will be 172.120.50.0/24
To configure the serial interface in Router1 :

>enable
>configure terminal
>interface Serial2/0
>ip address 172.120.50.1 255.255.255.0
>no shutdown

And likely, in Router2

>enable
>configure terminal
>interface Serial2/0
>ip address 172.120.50.2 255.255.255.0
>no shut

Now all links should be up and running and we should be able to ping each router on both its interfaces from the computers in its network.

step4

3. The last thing we need to do is to create a static route between the two Routers, so then we can ping from one network to the other.
To do this, we go to Router1 and type:

>enable
>configure terminal
>ip route 192.168.200.0 255.255.255.0 172.120.50.2

That tells the router, that it can get to network 192.168.200.0/24 via next hop 172.120.50.2, which is on Router2’s serial interface.

Now for Router2, we do something similar:

>enable
>configure terminal
>ip route 192.168.100.0 255.255.255.0 172.120.50.1

step5

Now finally, we have our static routes and we should be able to ping from any computer to any other PC and/or Router.

Concluding Thoughts:

Thanks for sticking around, this was a pretty simple lab to setup, but it’s good to start with really basic stuff and
practice it until you have it all figured out. Now, you can try adding more routers, switches, computers, and maybe
even servers. Play around with it and enjoy!

Share with Friends
FacebookTwitterLinkedInEmail
Use Cybytes and
Tip the Author!
Join
Share with Friends
FacebookTwitterLinkedInEmail
Ready to share your knowledge and expertise?
16 Comments
  1. I strongly disagree on how “Easy” packet tracer is. I don’t know who has the sense of humor at Cisco to actually give you equipment that does not work at times. I spent 19 hours with one system we built. We replaced the switch and cables between 2 floors and could not ping even from the switch to the router. We eventually had to get rid of the router and the pc and all the cables, drag in new ones. The instructor who designed the lab had 13 out of 28 student that could not make this work.(The others skipped the class) Eventually, after dragging in new equipment, and using all the EXACT SAME VLANS, IP ADDRESSES, RIPS, default gateways, and next hops, IT STARTED WORKING. This is version 7.0 and I don’t remember that happening with student 6.2

  2. great…. waiting for more examples.

  3. Great job, waiting for some more…

    🙂

  4. Great Post. Thnx for sharing info as well as the link..what a way to learn using simulation.. Keep up the good work

Page 1 of 41234»
Comment on This

You must be logged in to post a comment.

Our Revolution

We believe Cyber Security training should be free, for everyone, FOREVER. Everyone, everywhere, deserves the OPPORTUNITY to learn, begin and grow a career in this fascinating field. Therefore, Cybrary is a free community where people, companies and training come together to give everyone the ability to collaborate in an open source way that is revolutionizing the cyber security educational experience.

Support Cybrary

Donate Here to Get This Month's Donor Badge

 

We recommend always using caution when following any link

Are you sure you want to continue?

Continue
Cancel