CISCO Configuration Commands You Should Know

April 6, 2016 | Views: 7133

Begin Learning Cyber Security for FREE Now!

FREE REGISTRATIONAlready a Member Login Here

Navigation

Purpose

Command

Enter Privileged mode

enable

Return to user mode from privileged

disable

Access configuration mode

configure terminal

Exit Router

logout or exit or quit

Recall last command

up arrow or <Ctrl-P>

Recall next command

down arrow or <Ctrl-N>

Suspend or abort

<Shift> and  <Ctrl> and 6

Refresh screen output

<Ctrl-R>

Complete a command

TAB

 

Router Configuration

Purpose

Command

Set a console password to Cisco

 

This password is saved as clear-text within the config file

Router(config)#line con 0
Router(config-line)#login
Router(config-line)#password cisco

Set a remote access (telnet) password to Cisco

 

This password is saved as clear-text within the config file

Router(config)#line vty 0 4
Router(config-line)#password cisco Router(config-line)#login

Stop console timing out

Router(config)#line con 0
Router(config-line)#exec-timeout 0 0

Set the enable password to cisco

 

This password is saved as clear-text within the config file

Router(config)#enable password cisco

Set the enable secret password to peter.

This password overrides the enable password and is encypted within the config file

Router(config)#enable secret class

Protect clear-text passwords

Router(config)#service password-encryption

Hostname

Router(config)#hostname Router2

Enable an interface

Router2(config-if)#no shutdown

To disable an interface

Router2(config-if)#shutdown

Set the clock rate for a router with a DCE cable to 64K

Router2(config-if)clock rate 64000

Set a logical bandwidth assignment of 64K to the serial interface

Router2(config-if)bandwidth 64

To add an IP address to a interface

Router2(config-if)#ip address 10.1.1.1 255.255.255.0

Static route the remote network is 172.16.1.0, with a mask of 255.255.255.0, the next hop is 172.16.2.1

Router2(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1

To enable RIP for network 172.16.0.0

Router2(config)#router rip
Router2(config-router)#network 172.16.0.0

Disable RIP

Router2(config)#no router rip

To enable EIRGP with a AS of 200, for network 172.16.0.0

Router2(config)#router eigrp 200
Router2(config-router)#network 172.16.0.0

Disable EIGRP

Router2(config)#no router eigrp 200

To enable OSPF for backbone area (Area 0), for network 172.16.0.0/16. 123 represents the process ID (PID).

Router2(config)#router ospf 123
Router2(config-router)#network 172.16.0.0 0.0.255.255 area 0

Disable OSPF

Router2(config)#no router opsf 123

Disable CDP for the whole router

Router2(config)#no cdp run

Enable CDP for he whole router

Router2(config)#cdp run

Disable CDP on an interface

Router2(config-if)#no cdp enable

 

Show Commands

Purpose

Command

View version information

show version

View current configuration (DRAM)

show running-config

View startup configuration (NVRAM)

show startup-config

Show IOS file and flash space

show flash

View the interface status of interface fa0/0

show interface fa0/0

Overview all interfaces on the router

show ip interfaces brief

View type of serial cable on s0/0

show controllers 0 (note the space between the ‘s’ and the ‘0’)

Display a summary of connected cdp devices

show cdp neighbor

Display current routing protocols

show ip protocols

Display IP routing table

show ip route

Display access lists, this includes the number of displayed matches

show access-lists


Configuration Management

Purpose

Command

Save the current configuration from DRAM to NVRAM

copy running-config startup-config

Merge NVRAM configuration to DRAM

copy startup-config running-config

Copy DRAM configuration to a TFTP server

copy runing-config tftp

Merge TFTP configuration with current router configuration held in DRAM

copy tftp runing-config

Backup the IOS onto a TFTP server

copy flash tftp

Upgrade the router IOS from a TFTP server

copy tftp flash

 

Debug and Troubleshooting

Purpose

Command

Enable debug for RIP/OSPF

debug ip rip or debug ip ospf

Enable summary EIGRP debug information

debug ip igrp events

Enable detailed EIGRP debug information

debug ip eigrp transactions

Enable debug for CHAP or PAP

debug ppp authentication

Switch all debugging off

no debug all

undebug all

 

~ Hope this is useful to you ~

Share with Friends
FacebookTwitterLinkedInEmail
Use Cybytes and
Tip the Author!
Join
Share with Friends
FacebookTwitterLinkedInEmail
Ready to share your knowledge and expertise?
16 Comments
  1. I think this is really helpful. Thanks

  2. You should provide a pdf for this. great job

  3. Basic commands but very useful. thanks.

  4. Yep? Very helpful thank you.

  5. Wowww… this is great reference.

Page 3 of 3«123
Comment on This

You must be logged in to post a comment.

Our Revolution

We believe Cyber Security training should be free, for everyone, FOREVER. Everyone, everywhere, deserves the OPPORTUNITY to learn, begin and grow a career in this fascinating field. Therefore, Cybrary is a free community where people, companies and training come together to give everyone the ability to collaborate in an open source way that is revolutionizing the cyber security educational experience.

Support Cybrary

Donate Here to Get This Month's Donor Badge

 
Skip to toolbar

We recommend always using caution when following any link

Are you sure you want to continue?

Continue
Cancel